Cold trap turned to oven

Hello everyone!

We haven’t posted anything for a long time, because of a problem that forced us to invent solutions.

Everything was good. We installed everything in the Cool Tank and run last tests before adding liquid freon. We noticed that cold trap temperature raised too high up to 50+C.

Why this could happen?

Previously we noticed that pump was working a little bit noisy. The reason for noise was air in pipes. While we were fighting with air bubbles removal from water flow, cold trap cooling wasn’t effective enough and we got over heat.

Thermal elements inside cold trap melted. So we lost it. It was unique item made per our specifications with serial number 000001.

So now we fixed circulation problem by removing all obstacles from cold trap piping

Also added water meter to be sure, that we have circulation and to measure pump flow rate.

New piping around cold trap

And finally we tested the last survived thermal element. If we have efficient circulation able to remove heat, we should have temperature below zero on the other side of thermal element.

Let’s see:

Everything is ok now. That’s what we need from cold trap.

So, now we have to wait for replacement of thermal elements, assemble cold trap and proceed with start up on the next week.

To be continuing…

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s